Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Apollo Twin USB issue with USB 3.0

  1. #1
    Up and Comer
    Join Date
    Jan 2016
    Posts
    10
    Mentioned
    0 Post(s)

    Apollo Twin USB issue with USB 3.0

    Hello, I am a newbie. I just bought an Apollo Twin USB and knew it required 3.0 USB. Even though my PC is older (3 years), it has several 3.0 USB ports as well as a few 2.0 ports.

    Got everything registered, etc but in the process received a message that 3.0 is required. Silly me, I had plugged it into one of the 2.0 ports so I think, no problem. Well, this is where I am trying to figure things out. When I plug it into any of the blue 3.0 ports, the Apollo Duo is not recognized. Like it is not there. However, if I plug anything else into these ports (like mouse, keyboard, etc) they work fine. I unplugged the Apollo and plugged into one of the 2.0 ports and again, the Apollo is recognized but of course, I get the message that it needs the 3.0 USB port.

    I should mention I have not had any other devices requiring 3.0 prior to this purchase.

    To me this is weird. At first I thought my 3.0 ports were not working until I test them with everything else. I am trying to figure out if this is a problem with my PC or with the Apollo. I bought the Apollo as a demo from Sweetwater so I am wondering about that, too. Any advice?

    I am also sending an email to Sweetwater since they may have input, too.

    Thanks!
    Eddie

  2. #2
    UAD User
    Join Date
    Dec 2016
    Location
    North West UK
    Posts
    40
    Mentioned
    0 Post(s)
    Hi,

    I am a newbie too , and also got the twin USB system, My PC is quite old as well but works ok, ... Did you follow the Install video exactly as is says (I know ... but you're gonna get asked anyway), my advice would be to reboot and start over, if that doesn't work you may have to dig into the support manuals to check if your system is fully compatible.

    good Luck.

  3. #3
    Up and Comer
    Join Date
    Jan 2016
    Posts
    10
    Mentioned
    0 Post(s)
    Thanks for the reply!

    I did reboot several times and it is consistent in not recognizing only the Apollo except when I have it in the 2.0 ports. I will investigate further to see if I can get a clue somewhere about what might be going on.
    Eddie

  4. #4
    UAD User newyankee's Avatar
    Join Date
    Nov 2016
    Location
    Palo Alto, Ca
    Posts
    83
    Mentioned
    0 Post(s)
    Suggest that you might look at the possibility of updating your usb3 drivers.
    Apollo 8 BF Quad, Satellite Quad + Octo, Gigabyte Z170X Gaiming7,Intel I7 6700K, 32Gig Ram, Corning 10m thunderbolt cable, Win10 (1607), Cubase 8, Avid S3 Control Surface, Genelec 8351 monitors, misc old Apogee gear.

  5. #5
    Experienced UAD User Toxteth's Avatar
    Join Date
    Nov 2012
    Location
    Oslo Norway
    Posts
    324
    Mentioned
    0 Post(s)
    Try and ascertain whether your USB 3.0 ports are "Native" i.e. part of the motherboard, and not a "pci plugin board". Also, which USB 3.0 drivers and controllers are installed on your machine, not all controllers are accepted or supported...
    Obla Di Obla Da life goes on Bra...

  6. #6
    Up and Comer
    Join Date
    Jan 2017
    Posts
    3
    Mentioned
    0 Post(s)
    Try looking at your USB setup with this: USB Device Tree Viewer

    Does the Apollo appear on it at all when you plug it into a USB 3 slot?

  7. #7
    Shareholder
    Join Date
    Sep 2012
    Posts
    717
    Mentioned
    0 Post(s)
    Might check this thread out as well. Looks like the USB adapter you use is important.

    TH3 Adapters - Any That Work for Windows AND Hackintosh?

    Joe
    Pro Tools 12.8.1 HD Native | Logic Pro 10.3.2| 2012 MacBook Pro Retina 2.7GHz i7 | Apple Thunderbolt Display | 9.1.0 Apollo 8 Quad Blackface | Octo Card | Octo Thunderbolt Satellite | OSX 10.12.6

  8. #8
    Moderator Don Schenk's Avatar
    Join Date
    Jun 2014
    Location
    Anywhere with snow, mountains, ski runs, and a lift!
    Posts
    1,850
    Mentioned
    1 Post(s)
    Hi 1960es,

    There is a lot of info about USB setup and known issues on UA's website. Unfortunately there is a lot of USB info, and it is not at all well organized, and as such is very difficult to sort through. For example the Twin USB only works with certain USB chipset drivers.

    https://help.uaudio.com/hc/en-us/art...-Compatibility

    "Incompatible Windows Systems

    Computers that do not have USB 3 natively built in to the motherboard are not compatible with Apollo Twin USB.
    Using USB 3 adapters (such as PCIe-to-USB 3 adapter cards) are not compatible when used with USB 2 motherboards.
    Motherboards and PCIe to USB 3 adapter cards that use USB 3 controller chips from the following manufacturers are are not recommended for use with Apollo Twin USB:

    Texas Instruments
    Etron
    Fresco Logic
    ASMedia"

    More here:

    https://help.uaudio.com/hc/en-us/cat...pollo-Twin-USB

    https://help.uaudio.com/hc/en-us/sec...roubleshooting

    https://help.uaudio.com/hc/en-us/art...Chipset-Driver

    https://help.uaudio.com/hc/en-us/art...-USB-3-Details

    https://help.uaudio.com/hc/en-us/art...B-Known-Issues

    https://help.uaudio.com/hc/en-us/art...uired-Settings

    :- Don

  9. #9
    Up and Comer
    Join Date
    Jan 2016
    Posts
    10
    Mentioned
    0 Post(s)
    Thanks everyone for your advice! Awesome forum. Well, my 3.0 USB is not supported so good to know that the Apollo unit is probably okay. Like I mentioned, my PC is older so I think I will retire it to family use and buy a new PC but shop carefully to get one with compatible USB. I need to spent in the $800 range. For example, my local Costco has a i7 6700 HP Envy machine on sale for $699. I know it would depend on my uses. I mainly record instrumental music (jazz, blues rock, acoustic-celtic and old time) at home. Mainly myself and my 2 daughters who play violin/fiddle and guitar. Just for fun really. I play guitar, mandolin, bass.

    Again, thanks for everyone's guidance. I learned A LOT!
    Eddie

  10. #10
    Up and Comer
    Join Date
    Jan 2016
    Posts
    10
    Mentioned
    0 Post(s)
    Oops....meant to provide a link. Would this be compatible?

    HP ENVY 750-427c Desktop - Intel Core i7 - 2GB Graphics

Page 1 of 2 12 LastLast

Similar Threads

  1. Apollo twin usb windows registration issue
    By massimocapobianco in forum Support & Troubleshooting
    Replies: 2
    Last Post: 29th December 2016, 08:31 AM
  2. USB Apollo Twin Compatibility(?) Issue
    By Jphoenix44 in forum Support & Troubleshooting
    Replies: 4
    Last Post: 9th November 2016, 02:59 AM
  3. Replies: 4
    Last Post: 15th April 2016, 03:10 PM
  4. Apollo Twin USB issue - Non Communication
    By 519tbarr in forum Support & Troubleshooting
    Replies: 8
    Last Post: 23rd February 2016, 09:59 PM
  5. Replies: 3
    Last Post: 22nd September 2014, 04:50 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •