Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Apollo Twin Duo USB Asio Driver does not work in DAW

  1. #1
    Up and Comer
    Join Date
    May 2017

    Exclamation Apollo Twin Duo USB Asio Driver does not work in DAW

    Hi Folks,

    I have a weird situation.

    I first used my Apollo Twin Duo USB on a Asus P8Z77 V-Premium with a I7 3770K (1155) (Win 7 64 Bit) and it worked very well.

    I have changed MB and CPU to I7 K6850 (6 Processors) with a Asus X99 Deluxe II on Win 7 64 Bit and I am not able to record with Apollo on any DAW.

    I have Cubase 9 Pro and Studio One 3.

    I can hear Music normally with any Audio Player.

    However, when I start Studio One 3 it recognizes Apollo and a USB Asio Driver for it but it stops loading and states: Apollo... cannot be initialized and cannot start.

    On Cubase 9 Pro it does not even recognize the Asio USB Driver of Apollo.

    I uninstalled Driver of UA and reinstalled. I used all USB 3.0 ports. I unplugged all usb 3.0 ports and solely plugged in Apollo. No DAW recording possible.

    I am out of any idea.

    Is there a possibility to only download Drivers (without the 2 GB plugins) and install them separately?

    Has anyone the same experience or any idea to solve this problem?

    I really need to record with Apollo....

    You help would be really appreciated

    Thank You


  2. #2
    Experienced UAD User Toxteth's Avatar
    Join Date
    Nov 2012
    Oslo Norway
    Hi and welcome to this forum. Do you know that certain usb3 controllers will cause problems.

    from UAD's support pages:
    Motherboards and PCIe to USB 3 adapter cards that use USB 3 controller chips from the following manufacturers are are not recommended for use with Apollo Twin USB:

    Texas Instruments
    Fresco Logic

    Not saying that's your problem, but something to look at...
    Obla Di Obla Da life goes on Bra...

  3. #3
    Up and Comer
    Join Date
    May 2017
    Thank you.

    I was aware of that. Just surfed the Forum.

    I used the Intel USB 3.0 Connection (mid board) of the MB and I have purchased the KT4005 with the NEC Chip. Didn't help.

    Uninstalled UA newest 9.1 and switched back to original Driver which came with the Apollo ( also did not help.

    To be honest I do not like to uninstall several usb Drivers to get a single USB device running. That's not my imagination of plug and play.

    The System is quite new set. Simply a Music machine.

    Win 7 64 bit, Norton Security AV, Steinberg Cubase 9.0 Pro, Studio One 3, Steinberg Absolute 3, Native Instruments Complete 11, Toontrack, Focusrite 18i8 second Gen, Adobe Premiere and several Asio Driver of Music Instruments (E-Drums by Roland, Korg PX4, Roland GR-55, Line 6 POD HD 500x). That's all.

    I know Focusrite might be the Problem.

    Uninstalled Focusrite. No Change. Apollo ist not working properly.


  4. #4
    Master of the UADiverse Matt Hepworth's Avatar
    Join Date
    May 2005
    UT, USA
    Just for curiosity, does the same thing happen when Norton is disabled?
    PTHD> 2x Pro Tools HD4 Accel | 2x Mac Pro 8 Core (16 thread) | 2x Magma Chassis | Apogee Symphony I/O, AD16X, and AVID HD I/O | 2x UAD-2 OCTO, Solo | Pro Tools HD 10, HD 12 | Studio One V3 Pro | OSX 10.8.5

    NATIVE> nMP Ashtray/Trashcan Hex Core | OSX 10.10.4| Windows 8.1 Pro | Apollo QUAD "Classic" w/ TB, Apollo Twin DUO | TC Konnekt 48 | Samplitude Pro X | Studio One V3 Pro | SONAR Platinum | Pro Tools 12

  5. #5
    Up and Comer
    Join Date
    May 2017
    Thanks for asking, Yes, also not work when Norton is disabled.

    Changed a few things in the PC

    Now I got the message "Apollo Twin USB cannot be initialized" when starting Studio One V3 Pro...

  6. #6
    T11 is offline
    UAD User
    Join Date
    Jan 2012
    How did it go Werner?

    These are the steps I would go through:

    - Contact UAD support

    - Install the new 9.2

    - Download Korg USB-MIDI Driver Tools and choose:
    "Uninstall Korg USB-MIDI Device"

    (This little tool will list all your USB Midi-ports and show which ones are inactive/corrupted, after which you can delete those you might think may cause issues or simply just those you know you wont use again.)

    - For Win 7/8.1: Downloads | minilogue - KORG USB-MIDI Driver (for Windows 7/8.1) | KORG (USA)

    - For Windows 10: Downloads | minilogue - KORG USB-MIDI Driver (for Windows 10) | KORG (USA)

    - Upgrade BIOS

    - Check if I'd installed any screen capture program, VoiceMeeter or some other program which might try to put itself first in line in the computers audio chain.

    If none of that would help then I'd consider to:
    1. Uninstall Norton (and maybe replace it with MSE)
    2. Upgrade to a later Win-version

  7. #7
    Official UA Representative UniversalAudio's Avatar
    Join Date
    Oct 2013
    Quote Originally Posted by Werner_K View Post
    Thanks for asking, Yes, also not work when Norton is disabled.

    Changed a few things in the PC

    Now I got the message "Apollo Twin USB cannot be initialized" when starting Studio One V3 Pro...

    Hi Werner_K,

    You should contact UA Customer Support directly for help with this. They can step through your setup and possibly screen share with you.

    Please let us know how it goes!


    Gannon Kashiwa

  8. #8
    Up and Comer
    Join Date
    May 2017
    Thank you all for your kind support.

    This is getting really weird.

    I have tried 4 (!!) different PCIe USB 3.0 Extension Cards on a PCIe x16 Slot which has nor splitting of IRQ or bandwidth lanes with other on-board devices (I have a 40 lane cpu).

    NEC Chip, Renesas Chip, VIA Chip

    The Twin Duo now is plugged to a on-board Intel USB 3.0 slot.

    I have tried de-installing Korg USB-Midi Driver, de-installing Norton Internet Security. No Antiviruis Program installed. Changing to Kasperky Internet Security.

    Nothing helps... I have not one single entrance in the error protocols of windows (programs or system). Device manager tells me all system work. no error.

    I can hear Music over the Twin Audio and it is recognized in the Sound Manager.

    But dam... no DAW recognizes the ASIO Driver.

    Studio One 3 Pro does recognize the Twin Audio but it not able to initialize or start it.

    Cubase Pro 9 is not even recognizing the UAD USB Asio Driver. It only recognizes UAD Thunderbolt and UAD Firewire (although I have no device with either of the connections).

    I am not inexperienced in soft and hardware since I assemble all my PCs (over 10 in the last years) by myself and install all.

    That has never happened before. I am absolutely without any clue...

    Win 7 64bit. All drivers and windows up do date. Driver UAD 9.2 installed (de-installed prior version before installing 9.2 with shut down, no restart)

    Only MS office 365, DAWs, Anti Virus and music software (some instrumental usb drivers Roland etc.) nothing else on the Music PC.

    Twin Duo worked proper on P8Z77 and X99 deluxe (version 1) not on X99 Deluxe II from Asus.

    All chipset driver, USB driver and system driver are up-to-date. Focusrite 18i8 2nd gen. working also properly. This is off down when I try to work with Apollo twin. But is has parallel worked before on the P8Z77 with both Focusrite and Apollo Twin Duo.

    I really do not want to change to Win 10 because of the spying and forced updates. I do not like to have a handy system on a PC with massive more power. I also read Win10 is not that stable and do not work with all daws or software properly. And I hate tiles...

    What can I do?

    Your help would be really appreciated.



  9. #9
    T11 is offline
    UAD User
    Join Date
    Jan 2012
    Sorry to hear that Werner. Your best bet is probably to contact UAD support so they can help you find the cause of problem.

    (Don't think u have to be too afraid of Win10. It's stable and works great, at least better than my prev Win7. When u install it you can click 'No Thanks' to all report-to-MS-stuff. Also you can control the updates. There are plenty of guides out there for both of these things.)

    I hope that UAD will help u back on track. Good luck and hopefully u can report back the solution in this thread.

  10. #10
    Up and Comer
    Join Date
    May 2017
    Tried now with Win10 64 Bit. Same Error. Music: yes. Asio: not recognized...

Page 1 of 2 12 LastLast

Similar Threads

  1. Using Apollo Twin USB together with another ASIO audio device
    By gph in forum Support & Troubleshooting
    Replies: 6
    Last Post: 27th September 2016, 02:53 AM
  2. Apollo Twin Duo USB + Satellite Octo USB = Great combo!
    By Solidtrax in forum Apollo Interfaces
    Replies: 7
    Last Post: 14th July 2016, 04:07 AM
  3. Apollo Twin won't work with ASMedia USB 3 driver - any solution?
    By jono in forum Support & Troubleshooting
    Replies: 5
    Last Post: 11th July 2016, 02:01 AM
  4. Asio Error with Apollo Twin USB!!!
    By Pi Greco in forum Support & Troubleshooting
    Replies: 0
    Last Post: 22nd April 2016, 12:25 PM
  5. Replies: 10
    Last Post: 29th March 2016, 12:42 AM

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts