Behringer Controllers not working in Luna

After updating Luna, UAD software and Apple O/S my X-Touch One and X-Touch Expander no longer works in Luna, however they both still work in Logic Pro and Pro Tools. Is there known issue/conflicts With Luna, Tried resetting and re-installing but still no go. Any suggestion?
 
Are the controllers showing in Luna Settings?
Yes they both do. I set X-Touch One as Focus and X-Touch Extender as extender in the little check boxes under controllers tab.

I seen in thread there were some instructions on files that may need to be deleted and replace. Haven’t tried that because I cannot find thread now. If I find those files/instructions I will pass them on.

Thank you for quick reply.

P.S.
funny thing, I have an older I7 mini that I updated as well (backup machine) and that machine is running fine With all controllers, My main work station is a M1 ultra Studio; that’s the on with problem.
 

Matt Hepworth

Master of the UADiverse
Forum Admin
Moderator
I have a couple controllers sitting here. I'll see if I see the same issue.
 
Thank You. The controllers were until I did update, and I did all updates at once, so I’m not sure what update caused problem. After updates neither controller worked with any of the DAWs, after deleting and reinstalling the controllers in both Logic and Pro Tools they worked. Tried same for Luna and they do not work.
again thanks for help, I’m at lost.
 

Hector2

New Member
My Xtouch works pretty well with Luna. The only thing I can't do is using my FS-7 Boss switch to start and stop Recording . Is a problem with this equipment or is there a place in Luna where I can instruct the X Touch controller to do those operations?
 
Hello Hector, well i wish I had answer for you, but I never have used that type of control. I searched on my system for a setting however i did not see anything. I did find out during the testing/looking for answer for you that my Native Instruments S-49 and S-61 (verision 2) do not control Luna anymore now (that’s my start-stop-record Transport system).

My system is still not consistent. Switching between DAW’s still requires rebooting entire system 90% of time since the Apple Update/Luna update to get the Behringer controllers to work for any DAW. Not sure what update is the problem, honestly tired of messing with computers instead of writing music, seems like end users are the Beta testers anymore.

Unfortunately I have stop using Luna until I resolve this; my “work Around” is once I’m done tracking (mostly done in Logic due to me being a more MIDI than Audio) then I transfer the entire project to either Luna or PT to mix (all audio), both sound better to me than Logic on my system.

Good luck, if I stumble on to something I will post! Brad
 
My xtouch1 is 100% functional in Luna.
Don’t mean to brag, but to give hope.😊
2017 iMac
I have a “MIDI” set up with an older Mac Mini which is an i-7 ( my old system) and use a X-Touch Compact with that system, and It works great switching between the Luna and the Logic. I have not updated that is some time maybe that’s why!
 
UAD Bundle Month
Top