• Welcome to the General Discussion forum for UAD users!

    Please note that this forum is user-run, although we're thrilled to have so much contribution from Drew, Will, and other UA folks!

    Feel free to discuss both UAD and non-UAD related subjects!

    1) Please do not post technical issues here. Please use our UAD Support Forums instead.

    2) Please do not post complaints here. Use the Unrest Forum instead. They have no place in the the General Discussion forum.

    Threads posted in the wrong forum will be moved, so if you don't see your thread here anymore, please look in the correct forum.

    Lastly, please be respectful.

Can't get past 70% on the UAD meter!

macaroni

Active Member
I've got a G4, 1GHz, 1GB RAM, separate drives for system & audio (7200 rpm ATA/IDE), OSX 10.3.6, Logic 6 & 7, 2 UAD-1 cards, RME Multiface/PCI.

I've got some simple songs with around 10 tracks of audio and no instruments. If I load up the tracks with UAD plugs, with the UAD meter showing 70%-75%, the Logic CPU meter goes through the roof and I get Core Audio error messages - can't process the data. As I remove UAD plugins, the Logic CPU meter goes down.

What's going on? I know the Mac's CPU has to do a bit of work re the UAD plugins, but shouldn't I be able to at least run the UAD cards up to around 90% or so without putting any huge demands on the Mac's CPU?
 

mersisblue

Active Member
I have almost the same setup as you minus the sound card

I can get 90% are youi using a lot of native plugins ? if so you might notice if you freeze them you'll get better performance

is this in 6 and 7 ?
 

macaroni

Active Member
In these particular songs, I'm not using very many native plugins - 3 Logic plugins. And 2 of them are on tracks with the UAD plugins so I can't freeze them, since UAD plugins can't be frozen. The other one is an Ad Limiter on the master bus, set up to just prevent overs.

It appears that each new UAD plugin adds to Logic's CPU useage, which never happened in OS9. When the song is stopped, the Logic CPU meter is very low, and then when I hit play, it gradually rises and eventually chokes up.

This happens in both Logic 6 & 7.
 

mersisblue

Active Member
you running 3.7 other than that what is the pci layout?

I have echo mia

uad

uad

pci fan

AGP
 

mersisblue

Active Member
well Im just ran a test for you

I got 85 % while running safari and mail as well

using the mia echo card with buffer 1024 and process range medium

I was also running 8 virtual instruments nothing frozen
 

UAJames

Universal Audio
UA Official
Verify that you don't have AMD-8131 Mode check in the UAD-1 Meter's Configuration menu. You shouldn't see a host CPU load for each plugin added (you should notice a small amount for the first one, but not for subsequent ones). Also, how many UAD-1 plugins are in that session?
 

macaroni

Active Member
I don't have AMD-8131 checked.

Here's the track layout...

Mrdunga (clay drum) hi - PultecPro + LA2A + Logic Limiter
Mrdunga (clay drum) lo - PultecPro + LA2A + Logic Limiter
Harmonium hi - PultecPro
Harmonium lo - PultecPro
Tanpura via EXS24 - PultecPro
Vocal 1 - PultecPro + Fairchild
Vocal 2 - PultecPro + Fairchild
Aux 1 - EMT-140

(you should notice a small amount for the first one, but not for subsequent ones)
That's how it worked in OS9. When I took off a few PultecPro plugs, it lowered the Logic CPU meter and it stopped choking. I ended up bouncing the individual Harmonium and Tanpura tracks with the PultecPro. Now when I play the song, the Logic meter is about 50%, even though there's hardly any Logic plugs going.
 

UAJames

Universal Audio
UA Official
That shouldn't be putting an excessive load there. One test that would be good would be to run that session using Built-In Audio instead of the RME and see if the result is any different. If it is, it may just be a matter of tweaking UAD-1 and RME driver settings.
 

mersisblue

Active Member
have you trieed lowering the number of undos ? whats your buffer settings ?

dont want to get in the way UA james just trying to help

also try using built in audio
 

mersisblue

Active Member
my undos are set to 30

buffer 1024 and medium try that out and see if it works

worth a shot right ? :twisted:
 

UAJames

Universal Audio
UA Official
Yes definitely run a higher buffer. We recommend 1024 when you start loading up multiple instances as this is easier on the system in general. Also try experimenting with the process buffer size. Medium seems to work well for a lot of users as Mersisblue suggested. One last option could be to change the MIN_GNT setting in your UAD-1 Meter's Configuration menu to \"64\" if it isn't already (although a Built-In Audio test would prove if that would be necessary or not). If changing that setting doesn't make an improvement, just set it back.
 

macaroni

Active Member
I changed the RME buffer to 1024, Undos to 54, MIN_GNT to 64 from 128, Process Buffer to Medium.

It's definitely working better now and not choking up!!! :D

The Logic meter is behaving better too.

James - what Built In Audio Test should I run to determine the best setting for the MIN_GNT?

Thanks so much for helping out. I really appreciate it.
 

UAJames

Universal Audio
UA Official
For the Built-In Audio test, just select Built-In Audio as your audio hardware instead of the RME (note: you can do this if sample rates are higher than 48k) and see if the performance is any better. The RME stuff is so solid, there is rarely an issue with it so I don't think that is the case, most likely the higher buffer did the trick and the change in process buffer was the icing on the cake. In general, 64 seems to be the sweet spot for most users, so you should be fine leaving it there :)
 

mersisblue

Active Member
\" you CAN'T do this in sample rates higher the 44.1 \"

typo
 

UAJames

Universal Audio
UA Official
oops :) Yeah sorry, that \"can\" should be a \"can't\" basically if you are recording higher than 48k, you can't do the BIA test unfortunately.
 
UAD Bundle Month
Top