• Welcome to the General Discussion forum for UAD users!

    Please note that this forum is user-run, although we're thrilled to have so much contribution from Drew, Will, and other UA folks!

    Feel free to discuss both UAD and non-UAD related subjects!

    1) Please do not post technical issues here. Please use our UAD Support Forums instead.

    2) Please do not post complaints here. Use the Unrest Forum instead. They have no place in the the General Discussion forum.

    Threads posted in the wrong forum will be moved, so if you don't see your thread here anymore, please look in the correct forum.

    Lastly, please be respectful.

Does anyone have Sound Forge 9 working with UAD plugs..

Wiz

Active Member
I posted here a while back, about not being able to use UAD plugs in Sound Forge 9, and others had the problem..

Well I have been shooting emails back and forth with Sony (as someone said I would) and low and behold, they say, never heard of the problem...

Okay...8)..

Does anyone here have sound forge 9 running UAD plugs...

I cant use em..

I can preview the plug, but cant process...

Its obviously something to do with the plugs not being loaded...as I can see the plug in load when I preview it...but when I stop previewing, the plug in unloads, and then when I press the TICK to apply the plugin, it doesnt load, and I get a ERR=3 out of memory error....

So, just to check...

does anyone have sound forge 9 and get uad plugs to work...

and supplementary question...

anyone else reported this to Sony..


thanks in advance

Wiz
 

keano

Established Member
Hey man I tried it now and no UAD plugs odn't work with Soundforge 9 as is right now. I get a err-3 error. Have you contacted UAD?
 

Wiz

Active Member
well i guess the good news is its just not me...8)...

I have a support request in with Sony...

better put one in with UA...


cheers

Wiz
 

keano

Established Member
I put one in with sony, UAd and also Ik Multimedia for T-Racks also not working in SF 9.

I found a workaround for SF9 though. Uninstall SF9 and reinstall and DO NOT do the update to 9.0c
 

Fundy

Established Member
There is a bug with Sound Forge 9 with UAD-1 plug-ins at the moment although I am not sure about TC Electronic Powercore.
 

saemskin

Established Member
I have SoundForge 9, pirated from 4.5 upgraded from 5.0 purchased 7.0 upgraded from 8.0.... long time user here.

I normally use this for editing and converting and batch processing (awesome new feature in 8.0 btw). Last night I was trimming up some files and cleaning up the low end with the paragraphic eq when I remembered this thread and took a look.

PLim - works ok
PEQ - works ok
PBC - works and gives the demo warning
PMax - works and gives the demo warning

So I am not having any problems over here.
 

Jeff B

New Member
Here's the Fix

Hi,
I came onto this forum, desperate to fix the same problem.
Hadn't talked to anyone from either company who could help.
And forget Sony Media for that anyways- the guys at UA are great and stay on as long as you need them to...
anyways after a bit of web scouring, I did come across this and tried it and finally it works!
This wasn't just SF 9.0c, though.
I've had this in earlier versions of both SF and UAD. I also had a similar error in an older DAW, PARIS that I've worked with, and I'm not sure what the fix is for that, but obviously it's a streaming error.

So----
here's a paste from this other forum (ironically, the solution from UAD's Jor van Gelder)

Quote Jor van Gelder from UAD:
--------------------------------------------------------------------------------

This is a known problem that only occurs with the latest Sound Forge 9.0c update.

There is a simple solution and following these steps should resolve your problem:
1. Open Sound Forge, close any open files and remove any UAD plugins in use.
2. First, you can revert your sound device buffer sizes back to the previous settings.
If this isn't configured already, we do recommend that you always use ASIO with Sound Forge and the UAD plugins (Options>Preferences...>Audio... Your ASIO device must be selected for \"Audio device type\")


Now you need to change some \"internal settings\" in SF9 as a fix for your original problem:

1. Hold down Ctrl+Shift while selecting Options>Preferences...
2. Select the “Internal” tab
3. Type in “sfaudstrm” in the edit box at the bottom
4. Find the entry labeled “Default SfAudStrm read size”
5. Change the Value cells to:
Default SfAudStrm read size 131,072
Default SfAudStrm read cache 2,097,152
6. Tab or click away from the cells to commit the values, then click OK
7. Restart Sound Forge

UAD plugins should now process correctly in SF9c.

Sony has informed us that this problem will not occur again in future updates of Sound Forge which will maintain these compatible settings.

--------------------------------------------------------------------
This'll do it

Regards,

Jeff
 
UAD Bundle Month
Top