• Welcome to the General Discussion forum for UAD users!

    Please note that this forum is user-run, although we're thrilled to have so much contribution from Drew, Will, and other UA folks!

    Feel free to discuss both UAD and non-UAD related subjects!

    1) Please do not post technical issues here. Please use our UAD Support Forums instead.

    2) Please do not post complaints here. Use the Unrest Forum instead. They have no place in the the General Discussion forum.

    Threads posted in the wrong forum will be moved, so if you don't see your thread here anymore, please look in the correct forum.

    Lastly, please be respectful.

Extra buffers

RWIL

Established Member
Hi,
I found that it's little unusual that the value in registry which stores the «Extra buffers» setting (Under New DMA settings from UAD config) is +1? If it sets = 0 in dialog, registry store 1; if it sets = 1, registry = 2; and so on! Am I alone?
I think I will try to tweak manually the value (=0) and see... :D

Cheers,
RW
 

RWIL

Established Member
Well for now if I tweak the value in registry = 0, UAD report «Extra buffers» = 0 again, like when registry = 1. Really strange! Seems fine but have to push....
Why I'm doing that? It is because since little time I'm getting strange behavior using the Boss CE-1. I have now a saved little project (SX3) where as soon I switch ON the CE-1 I'm getting glitch, and only with that plug. Now what I discover is that I have also a Plate 140 on another fx track which is off and bypass, and as soon I switch on the Plate (bypass still off); the glitch from the CE-1 stop!?! Who is the culprit? SX, corrupt cpr file, UAD?
 

Fundy

Established Member
If you set the value of the Extra Buffers too 0, you are effectively disabling them. It would reset the value to 1 or use any factory settings to restore stability.

\"To configure the UAD for Cubase and Nuendo large ASIO buffer size support:
1. Launch the UAD Performance Meter.
2. Open the system menu by clicking the icon at the upper left of the Performance
Meter and select the ‘Configuration’ option.
3. Increase the Extra Buffers control until “New latency” matches the current
buffer size of the ASIO device.
4. Reset the ASIO device using one of the following methods:
•Close the re-open the session
•Stop then restart the audio engine
•Modify or reset the audio device settings
5. The “Current latency” display should now match the “New latency” display.
Configuration of Extra Buffers is complete.\"

from the UAD pdf.
 

RWIL

Established Member
Fundy said:
If you set the value of the Extra Buffers too 0, you are effectively disabling them. It would reset the value to 1 or use any factory settings to restore stability.
Hi Fundy,
Yes I already read about the .pdf infos. It's not the point.
From the UAD's performance dialog, the default value is Extra buffers =0,
and which IMO mean no extra buffers (= disable). But that value is store =1 in registry. When I change manually the reg value to =0, the UAD's performance dialog reports Extra buffers =0 again. So for me the question remains: Why that value is stored +1 in the registry?

RW
 

Akis

Sadly, left this world before his time.
Moderator
Because apparently '1' in the registry means '0' for the UAD drivers? I don't see what the problem is with that.
 

RWIL

Established Member
Akis said:
Because apparently '1' in the registry means '0' for the UAD drivers? I don't see what the problem is with that.
Hi Akis,
It is just intriguing! At least for me..., and more over when you try to track a problem.

Cheers,
RW
 

Akis

Sadly, left this world before his time.
Moderator
Oh, I didn't realise you were troubleshooting; thought you were just experimenting. Anyway, I don't think that would cause a problem, so if I were you, I'd look elsewhere.
 

jwnc

Member
I am using Nuendo 3 should I do what Fundy said about changing this? What good does it do?

Thanks
Jason
 

DanRichardson

New Member
troubleshooting something else,
and saw this thread hanging with an answer that I knew...

from the same PDF -

Note: Extra Buffers are not required for Cubase/Nuendo version 2 or
higher, Logic Audio, or Mac OS.
 

GregJ

Member
To me, the Extra Buffers setting in the REGISTRY being = 1 simply means that the buffer setting in the UAD window is ACTIVE. If it were =0 in the REGISTRY, then no extra buffers in the UAD window would be active.

In the Windows registry: 1=enabled feature
0=disabled feature

I think that's how it works.

GregJ
 
UAD Bundle Month
Top