OBS, Cubase , Apollos (X8, X4)

BangkokB

Member
Hello guys,

I've just spent the last 7(!) hrs trying to get this set up working to record the apollo outputs into OBS.

I have a reasonably complicated set up with external hardware and synths set up as external instruments and external FX in Cubase. I've tried various workarounds with Blackhole and other loopback substitutes. Its been a bit of a nightmare. Any aggregate devices or multi-output devices immediately reset my outputs on all my hardware FX and synths etc in Cubase. Very frustrating. Anyone managed to get this combination working specifically on Cubase (not Ableton...yes I've watch that video.)

I believe the root of the problem is OBS only being able to listen to channels 1& 2 (or something like that.) Can I mirror the mains in some way - man this should be so easy...it doesn't seem to be :-(

Mac M1 Max, Cubase Pro, Apollo X4, X8

Thanks in advance
 

BangkokB

Member
Hello guys,

I've just spent the last 7(!) hrs trying to get this set up working to record the apollo outputs into OBS.

I have a reasonably complicated set up with external hardware and synths set up as external instruments and external FX in Cubase. I've tried various workarounds with Blackhole and other loopback substitutes. Its been a bit of a nightmare. Any aggregate devices or multi-output devices immediately reset my outputs on all my hardware FX and synths etc in Cubase. Very frustrating. Anyone managed to get this combination working specifically on Cubase (not Ableton...yes I've watch that video.)

I believe the root of the problem is OBS only being able to listen to channels 1& 2 (or something like that.) Can I mirror the mains in some way - man this should be so easy...it doesn't seem to be :-(

Mac M1 Max, Cubase Pro, Apollo X4, X8

Thanks in advance

Nobody have any insights at all?
 

BangkokB

Member
OK...in the absence of some help I found the solution. I'm posting this here to help others who may have the same issue. This is Cubase specific and it took me more than a day to fix this.

1. Download BlackHole from Existential Audio and install. Just the 2ch version, for reasons which will become obvious later on.

2. Open Audio Midi Setup on mac. Create another aggregate device by clicking on the little plus icon.

3. In the window that pops up you will see a selection box. *NOTE* Mac computer has to be first in the list, don't know why, ask apple. Select Apple computer, BlackHole, Universal Audio.
Now, this is where the next issue lies. Many of us will have tidied our inputs and outputs in our matrix and software to only show us the in/outs we are using (I'm not usuing the Adat's for example) Unfortunately the aggregate device doesn't know this and includes ALL inputs and outputs to every device listed - more than 50 in my case just for UA. To add to that complication it offsets the inputs and outputs by the inputs and outputs in front of it - but not for the mac inputs (???FFS!!). so what was 1, 2 is now 3 or 4 for example.

4. Expand the Added device window to see the full range of inputs and outputs - these are luckily color coded.

5. Note the OUTPUT number for black hole ...this will be very important later!

6. Open Cubase - SAVE ALL YOUR AUDIO CONNECTION SET UPs in the Audio connections window -

7. Go to Studio set ups change the Audio driver to Aggregate device or whatever you have named it. BEWARE, this will completely change ALL of your inputs and output configurations in Cubase, make sure you save first and take pictures just incase!

8. Reset all you inputs outputs to the correct designation (yes, a pain) when it is all routing correctly...save the pre-sets as Aggregate device or your name of choice.

9. Open the control room tab in Audio Connections. Add a new Cue mix if you dont have one.

10. Set the audio driver to aggregate device.

11. SET THE OUTPUT TO THE CORRESPONDING CHANNEL NUMBER FOR BLACK HOLE YOU NOTED IN STEP 5

12. Go to the Cubase mixer and enable the cue send view

13. On the master channel. Enable the Cue mix

14. Open OBS.

15. Add new Audio capture, name it (Cubase say)

16. click on the three dots next to the new capture channel

17. From the list available select BLACK HOLE, Not UA

....it should now be working!

Phew...this was a long road with nothing I could find to trouble shoot this. Hope it helps someone out. Cheers
 
UAD Bundle Month
Top