• Welcome to the General Discussion forum for UAD users!

    Please note that this forum is user-run, although we're thrilled to have so much contribution from Drew, Will, and other UA folks!

    Feel free to discuss both UAD and non-UAD related subjects!

    1) Please do not post technical issues here. Please use our UAD Support Forums instead.

    2) Please do not post complaints here. Use the Unrest Forum instead. They have no place in the the General Discussion forum.

    Threads posted in the wrong forum will be moved, so if you don't see your thread here anymore, please look in the correct forum.

    Lastly, please be respectful.

RDRAM check failed


I installed my new UAD-1e card today and in my device manager it say's it's working properly.When I open the UAD-1 meter it say's my card was not found and RDRAM check failed.What does this mean?


Established Member
Sounds bad, but email UA support and I am sure they will fix you up one way or another :)


Yeah..........i've tried everything.Re-installed about 10 times.What's weird is Window's say's it functioning properly yet the software can't find the card.I emailed UA and Sweetwater(where I bought it)and hopefully it get's resolved soon.

1 thing I forgot to add is the initial install worked fine and I got my card ID and authorized the card.Next bootup nothing.Weird.
UAD Bundle Month