• Welcome to the General Discussion forum for UAD users!

    Please note that this forum is user-run, although we're thrilled to have so much contribution from Drew, Will, and other UA folks!

    Feel free to discuss both UAD and non-UAD related subjects!

    1) Please do not post technical issues here. Please use our UAD Support Forums instead.

    2) Please do not post complaints here. Use the Unrest Forum instead. They have no place in the the General Discussion forum.

    Threads posted in the wrong forum will be moved, so if you don't see your thread here anymore, please look in the correct forum.

    Lastly, please be respectful.

RESOLVED: Waves and Penryn buyer beware!

jcschild

Member
HI,
does anyone have Waves working on the newer Penryn (45nm) processors?

according to Waves tech support:
Waves is not supported on 45 nm processors, no work around and not know when the fix in the future will be.

so lets think about that

thats ALL of Apples new lines
thats all of any big box company (dell etc)
that most of the pro audio builders aside from a the slow adobters.

so 99% of new computers cant run waves?

time to buy more UADs
 

DAWgEAR

Active Member
Re: Waves and Penryn buyer beware!

Can you disclose what the incompatibility is? Which versions of Waves plugins it applies to?

My new system is based around a Q9450. I use Cubase 4. I have Platinum, Tune, SSL/API/V-Series.

Waves 5.9.7, which worked on my old AMD X2 4400 based system, had major issues when installed on the new system. Specifically, I could not see the plugin GUI, only a version of the generic Cuabse GUI (Ctrl+Shift+Alt when loading plugin), except that the GUI had one slider and did not function.

So I reverted back to version 5.2 (or, in the case of the SSL/API/V, the latest version before 5.9.7). That has been working without any issues.
 

docdune

Member
Re: Waves and Penryn buyer beware!

Yes, exact same problem as you. Waves SSL v5.9.7 doesnt work on a Quad core Zeon E5420 (Penryn 45nm).
WTF Waves? I just bought the SSL but wasnt aware of the compatibilty issue at the time.
 

billybk1

Shareholder
Re: Waves and Penryn buyer beware!

docdune said:
Yes, exact same problem as you. Waves SSL v5.9.7 doesnt work on a Quad core Zeon E5420 (Penryn 45nm).
WTF Waves? I just bought the SSL but wasnt aware of the compatibilty issue at the time.
Maybe it is more of a Quad core Penryn issue. I say this as I am successfully using WAVES (including SSLv 5.9.7) with my Duo Core e8400 (3Ghz) Penryn 45nm. I just had a project playing back (using SONAR 7) without issues using up to (35) WAVES plugins (including several SSL plugins) and another similar project (35 WAVES plugins) in REAPER, as well.
 

billybk1

Shareholder
Re: Waves and Penryn buyer beware!

DAWgEAR said:
Waves 5.9.7, which worked on my old AMD X2 4400 based system, had major issues when installed on the new system. Specifically, I could not see the plugin GUI, only a version of the generic Cuabse GUI (Ctrl+Shift+Alt when loading plugin), except that the GUI had one slider and did not function.
In SONAR 7, you need to turn off it's "X-Ray" windows feature in order to see the GUI. Otherwise, the plugins work as they should.
 

jcschild

Member
Re: Waves and Penryn buyer beware!

i think its the new VST wrapper so that may be why the older version worked.

i am going to try a variety of CPUs in the system today Dual and quad
odd that Waves said ALL 45nm, yet the dual core is working?
 

Giles117 DP

Active Member
Re: Waves and Penryn buyer beware!

It is a weird problem. My Quadcore has those issues. I can see the gui, then.. when closing windows, the gui disappears in other open waves windows...

However, I can re-open the windows and all is well.

Waves is a flake anyway. LOL (No Penryn here) SO If I have that issue. hmmm Maybe I should hold off on my Q9300 upgrade....
 

jcschild

Member
Re: Waves and Penryn buyer beware!

supposedly Waves has now fixed the issue with a new updater.
i have not verified it works.
 

Matt Hepworth

Master of the UADiverse
Staff member
Forum Admin
Moderator
This issue also affected Sound Forge. The Waves patch fixes the issue. I have confirmed it.
 
UAD Bundle Month
Top