• Welcome to the General Discussion forum for UAD users!

    Please note that this forum is user-run, although we're thrilled to have so much contribution from Drew, Will, and other UA folks!

    Feel free to discuss both UAD and non-UAD related subjects!

    1) Please do not post technical issues here. Please use our UAD Support Forums instead.

    2) Please do not post complaints here. Use the Unrest Forum instead. They have no place in the the General Discussion forum.

    Threads posted in the wrong forum will be moved, so if you don't see your thread here anymore, please look in the correct forum.

    Lastly, please be respectful.

UAD stealing system memory (300 MB per card)

Agent Cooper

Established Member
A question for the experts :

Situation :
Asrock board Conroe 865, Intel 865 chipset
CPU E6700
VGA 6200/128 MB
3x UAD PCI
RME Digiface PCI

Until now I used 2 GB RAM, everything perfect, Prime Orthos >>8 hrs stable
Put in 2 extra modules for a total of 4 GB.
in BIOS setup all 4 (identical) modules are recognized ok.
At the very first boot screen however the board only shows 2600+ MB with the 3 UADs installed.
Removing UADs one by one restores about 300 MB of memory each, up to 3500 MB + without UADs.
Removing the RME makes no difference at all.
Exchanged the board for a new one, no difference.
Tried the 4 memory sticks in another system with identical board (Cel. 3.06, no PCI cards, TI4200/64MB) gives 3800+ MB.

Please don't even consider a Windows problem, all the above takes place immediately after switching on the PC at the very first boot screen.

I'm aware the I865 doesn't support memory remapping, but from all I could find in the web I was expecting 3.5 to 3.8 GB and that would be fine with me.

Any help / explanation would be appreciated, I don't know what else to try, Asrock support is clueless.

Cheers, Cooper

Fwiw, I'm not necessarily saying this is a UAD problem, but it's directly connected to the cards.
 

T-Dogg

Active Member
All PCI cards require space to be allocated within the memory table registers. A video card, for example, may reserve as much as twice it's onboard memory capacity. While 300MB seems a bit steep, I'd expect at least 128MB per UAD card, but possibly more depending on your motherboard's buss handling. It's not so much that the card is using your physical RAM -- but it is \"stealing\" registers in memory tables that it will use to communicate through, and in doing so it detracts from the space Windows has available to load your physical RAM.

It really does boil down to a windows issue -- 32bit versions of Windows can address a maximum of 4gigs of memory space. Before, when you had 2gigs, windows would load your physical RAM into the lower registers of this memory table, then reserve memory space for PCI/System buss devices in the higher unused registers of this table. This makes sense in most configurations, since most folks don't use 3-4gigs of RAM... Now that you've added that extra 2gigs, you've taken up all the space in the memory allocation table that 32bit Windows can handle. BIOS will give priority to your hardware before allocating all your physical RAM, so as a result you're left with a couple hundred MB's of RAM your computer doesn't even know exists (note that some bios have setting to load PCI devices into very high registers, allowing your RAM count to display the full 4gigs, but this is only to be used with 64bit OS's).

This is one of the issues 64bit OS's like Vista solve... Hope this helps.
 

T-Dogg

Active Member
EDIT -- sorry, just saw what you said about memory remapping, so you probably knew the above.. It's up to the motherboard to determine how much memory to allocate to each card... Mine reserves about 128MB per card (I think, but maybe it is 256MB.) Your only other option is to try a new MOBO in hopes that it will allocate less than 300MB per card, or upgrade to a 64bit OS and a MOBO with remapping...
 

Agent Cooper

Established Member
T-Dogg,
thanks for your very informative reply !
Looks like I'm simply SOL here and stuck with my 2.6 GB. :(
I noticed yesterday there is at least one modern ASUS board with 4 PCIs and S775, so I'm gonna get me a Kentsfield and the rest of the stuff later this year when CPU prices have come down a bit.
Hopefully there will be user reports of that combination until then.
OS is no problem, I got XP Pro and XP64 on that machine, XP64 working with UADs but not with NI.
Cheers,
Rhino
 

T-Dogg

Active Member
No problem, I'm actually kinda in the same boat you are... I got 4GB of RAM and a MOBO that does support remapping... So my workaround was to install Windows 2003 Server Enterprise, which through some clever programming can allocate 32GB of memory despite the fact that it is still a 32bit OS. Sounded good in theory.

Till I tried it, and realized that most 32bit drivers are not coded to access registers above the first 4gigs. So my video card driver couldn't talk to the video card, the UAD driver couldn't talk to the UAD, etc. I could go to a 64bit OS, but unfortunately I own an original Hammerfall soundcard, and RME has said they will not release 64bit drivers for it. So I'm SOL too, unless I want to buy into a new soundcard along with the OS upgrade... :cry:
 

JamesR

Active Member
did you put the /PAE extension in you boot.ini ?

J.
 

T-Dogg

Active Member
I was able to get it up and running with 4GB visible using the /PAE switch and the memory remapping feature on my MOBO, but was plagued with constant driver/performance issues. UAD-1 card didn't work, and video driver caused immediate freezing on any screen refresh... Standard Windows VGA driver did work, but nearly every card on the PCI buss has communication issues. Although now that I think about it -- I don't know if I tried reinstalling the driver's while the PAE kernel was running, think I was just toggling through lines in my boot.ini... Hmm... I'ma try it tonight!
 
UAD Bundle Month
Top