• Welcome to the General Discussion forum for UAD users!

    Please note that this forum is user-run, although we're thrilled to have so much contribution from Drew, Will, and other UA folks!

    Feel free to discuss both UAD and non-UAD related subjects!

    1) Please do not post technical issues here. Please use our UAD Support Forums instead.

    2) Please do not post complaints here. Use the Unrest Forum instead. They have no place in the the General Discussion forum.

    Threads posted in the wrong forum will be moved, so if you don't see your thread here anymore, please look in the correct forum.

    Lastly, please be respectful.

UAD1 & Sonar - the final thread - 3rd time's a charm 1/2


New Member
-Music xpc S2, sonar 5.2, UAD 4.3-

Hi all, I'm writting this to both the UAD forum and the cakewalk VST adapter beta forum. I've usually been pretty good at trouble shooting most of my issues related to gear and software, but like most of you I
often bang my head against the wall when it comes to running simple projects consisting of Sonar as a host, and a few plugin running on the UAD cards.

I'm here to tell you about my latest findings wich you might find interesting, no matter the type of problem you're experiencing. I hope some of you can confirm what I'm about to share with you, and maybe
even duplicate the situation in order to validate the problems so we can zero in on the real problem and ZAP IT.

I'm sure most of you have had a session consisting of a few audio tracks, a couple of soft samplers and a couple of UAD plugs, and have maybe felt that the more you were adding to the session the \"heavier\" it got.

Today, I was working on a simple session, a Kontakt 2 vst softsampler, 19 audio tracks with some Waves plugins on most of them, and another audio track with 1 (one!) UAD pluggin on it, the mighty pultec pro. The latency of my system was fixed at 256 samples, but it sure did not feel like a 256 sample latency when playing parts in real with kontakt 2. It seems to be late somehow... it seemed like the latency was more 512 or even a bit more... anyway just not playable or acceptable in order to vibe along the track.

I decided to find EXACTLY what was happening and why.

I closed the project and opened a brand new one, loaded Kontakt, loaded the sames patches than the ones in my problematic session, started to play... all was well. it felt right, no latency awckwardness.

I closed the project and loaded the problematic session. without pressing \"play\", I simply started to play the exact same patches with my midi keyboard... felt wrong right away.

Fresh from my fine experience with kontakt in an empty project, I decided to delete channels, one by one, until I could find the culprit. I deleted the 1st 19 tracks of audio with wave plugins on them and the

latency shift was still there. I finally deleted the 1 audio track with the Pultec pro on it... and magic. all was fine.

I then decided to try an experience. I opened a new project with 2 audio tracks and 1 midi track. on one audio track I loaded an instance of kontakt, and on the other I loaded a stereo audio file and strapped 2 pultecs on it. I routed the midi track to kontakt and started to play a few notes. latency was even bigger than in my problematic project!

I pushed the experience further by loading 4 more pultecs (for a total of 6). wow. latency felt drasticly MORE delayed! and my fixed latency was still 256!.

I decided to fix my latency at 128 samples, and added 6 more pultecs (for a total of 12). Mongloid latency! at least 300ms. completly unplayable and unusable.

I then deleted all of the pultecs, and loaded 15 LA2's. Same thing.

I deleted those and loaded 12 1176. Same thing happened again!

I decided to try the same but with non UAD plugs. I loaded about 14 URS neve vst plugins and latency was FINE!! no problem. no awckwardness, quick as a 128 sample latency can be. instantanous, perfect.

I started to get worried... I mean how can loading UAD plugins affect the playability and performance of a softsampler, that resides on a completly different audio tracks! I pushed the investigation further and things got really interesting:


New Member

I reloaded about 13 pultecs, deleted kontakt, and loaded re-fx PLASTIZ, an virtual analog vsti. I started to play, and guess what... everything was fine!

I deleted Plastics and loaded Ni BATTERY. things were not fine anymore!

I then tried this : I unchecked (de-activated) all of the 13 pultecs. the playback of battery was still screwed up.

I then Archived the actual track where the 13 pultecs were. the playback was still screwed up!

I deleted the track where the 13 pultecs were... The playback of Battery was fine.

It's almost like the actual code of those plugins was faulty, and as long as they reside in the memory, they will keep screwing around with latency of RAM streaming/ HDD streaming audio engines (Battery, Kontakt, heck even sonar audio engine maybe!)

I decided to try one last thing... I remembered I had read somewhere on the cakewalk vst adapter forum that the UAD plugins were'nt written in order to be delay compensated by a host program like sonar.
So I launched the cakewalk vst adapter app... did a quick scan of the vst plugins and then clicked on the properties for the pultec pro. I saw that \"enable delay compensation was checked\"

I thought \"what the heck, I just will try and uncheck it\"

Loaded the test project, loaded my 13 pultecs (that were now not delay compensated) and my kontakt... and everything played FINE.

Try to duplicate this if you have 15 min and tell me if you experience the same issues.

I am no software engineer but I still think that we can draw a few conclusions here.

1) : UAD's, when delay compensated, screw up with any audio streaming engine or sub-engine (softsampler reading audio from RAM or HDD, and probably Sonar's audio engine itself. I mean... UAD's acually slow down
the latency without even warning you!!! how many time have I wondered \"why the hell is the song not feeling right anymore\" or \"how come I'm not able to nail the part correctly\" - and I've got fine chops, timing has never been an issue for me when playing live and/or to a click (just thought I'd give that precision;)

2) the problem seems absent when using UAD'S along softsynths that do not require RAM of HDD reading of audio files or samples (mostly virtual analog synths. FYI I also tried one Arturia vsti, and had no problem)

3) Is the problem solely related to the vst wrapper? I absolutely don't think so. I mean I have tried to duplicate the UAD weirdness with URS vst's, Waves Dx's, Blue Tubes vst's... ONLY the UAD's are screwing things up!! and this brings me to my 4th point :

4) UAD, Cakewalk, please be honnest with us paying customers. there is a BLATANT problem here that makes the usage of sonar with UAD simply UNTHINKABLE... not even merely workable unless you're using 3 plugs on
your 4 UAD1 cards and don'T care about the tightness of timing within your projects. If the issue is NOT resolvable we NEED TO KNOW so we can move on because this has been going on for a few years now and it still is a nightmare, and a simple workaround with a vst adapter fix seems to be just as effective as a band aid on a wound that is too big to be closed. we need this to work ROCK SOLID, nothing less! and again, if it cannot be done we deserve to know about it. we paid a lot of money to buy your sofwares and your hardware, the least you can do is be honnest with us and admit to us if there is just noway to work things out.




Bravo..., but don't hold your breath. Is the workaround to uncheck \"enable delay compensation\" and use UAD track advance?
UAD Bundle Month