Unable to purchase Apollo Twin MK II plug-ins

Pepperhead

New Member
Hi, I’m new to this. I purchased an Apollo Twin MKII and a Mac Mini with the M2 chip, 32GB of RAM and a 1TB SS drive. I have the software installed and have recorded a few of my compositions using the included plug-ins. Now of course I’m looking to expand. I tried to purchase the UAD Ultimate 12 bundle with over 100 plug-ins, on sale for $999. When trying to add it to the cart however, it says I need an Apollo or Satellite to purchase and will not add it to my cart. Is the Apollo Twin MkII not considered an Apollo?? What’s up with this? I thought I could purchase and add as many plug-ins as I want. Thank you for any assistance you can offer.

~ Big Mike
 

UniversalAudio

Official UA Representative
Hi, I’m new to this. I purchased an Apollo Twin MKII and a Mac Mini with the M2 chip, 32GB of RAM and a 1TB SS drive. I have the software installed and have recorded a few of my compositions using the included plug-ins. Now of course I’m looking to expand. I tried to purchase the UAD Ultimate 12 bundle with over 100 plug-ins, on sale for $999. When trying to add it to the cart however, it says I need an Apollo or Satellite to purchase and will not add it to my cart. Is the Apollo Twin MkII not considered an Apollo?? What’s up with this? I thought I could purchase and add as many plug-ins as I want. Thank you for any assistance you can offer.

~ Big Mike
Sounds like you bought used and have not registered it to you account.

Do you see if on the site in "My UA Hardware"?
 
UAD Bundle Month
Top